TQM Issue: 08-07-2024 - IDC OmniSense Onboarding Failure

CX TQM Issue

https://tforge.atlassian.net/browse/CP-241

Date of Issue

Jul 8, 2024

Duration of Issue

Ongoing

Area of Failure:

Process, Technology, People

Impact

Major

Stakeholders

Facilitator

@Adele Diedericks

Stakeholders

  • @Rijnhard Hessel

  • @Saba Rahimi

  • @Vishane Naicker

  • @Monray De Jager

Customers

  • IDC

History of Events

  1. Customer onboarding recurring issues encountered with the implementation of the OmniSense solution

  2. During testing and go live phases, the customer has logged multiple complaints regarding the solution

  3. there were delays in the implementation go live

  4. There are integration issues identified which needs urgent resolution

  5. We have identified application bugs in the solution that requires urgent attention

  6. There are networking issues identified at the various branches which causes downtime

  7. All of the above issues called for urgent intervention and resolution in order to retain this new customer

Actions

Set Meeting Date 8 July 2024
Draft Actions:
Integration issues
Application bugs
Networking issues

 

Meeting Attendees

  •  

Outcomes

Root Cause

Final RCA to be determined post investigations and resolution summary by @Rijnhard Hessel @Saba Rahimi

Resolution Summary